Personal Website

My Web: MindEchoes.com

Friday, October 29, 2010

Google App Engine Roto en Ubuntu 10.10

Para quienes hayan instalado Ubuntu 10.10 y quieran usar el servidor de desarrollo de Google App Engine se van a encontrar con la misma sorpresa que me encontre yo:
NO ANDA!!

Pero... arreglarlo es muy fácil!
Google App Engine requiere Python 2.5, esta reportado que con 2.6 o superior se rompe:

Simplemente tenemos que instalar Python2.5 que por defecto no lo vamos a encontrar en el repositorio.
Intente compilarlo e instalarlo, y corría Python, pero seguía sin funcionar con Google App Engine, me tiraba una excepción de que faltaba un módulo.

Y después encontré esta solución (Agregando un repositorio para instalar Python2.5):

sudo add-apt-repository ppa:fkrull/deadsnakes  
sudo apt-get update  
sudo apt-get install python2.5  

Una vez que realizamos eso, solo tenemos que hacer:

python2.5 dev_appserver.py [path-proyecto]

Y Listo!
Problema solucionado!

No comments: